Exchange account creation not working
Incident Report for One.com
Resolved
Account creation is now working again.
Posted Feb 02, 2024 - 16:17 CET
Identified
It is currently not possible to create new Exchange account in our control panel. We are working on fixing this. We wil provide updates here, when we have some.
Posted Feb 02, 2024 - 15:41 CET
This incident affected: Partners (Microsoft Exchange).