Issues with mail services

Incident Report for one.com

Resolved

Webmail access has now been fully restored, and all systems are verified to be working as expected again.

If you are still having problems accessing related services with us, please contact us on chat or email here: https://www.one.com/chat.
Posted Sep 22, 2026 - 10:42 CEST

Identified

The root cause of the issue has been identified and our engineers are working to implement a fix.

Next update no later than 10:50 CEST.
Posted Sep 22, 2026 - 10:22 CEST

Investigating

We are currently facing an issue with our webmail, mail.one.com, throwing a blank page.

It is being investigated as we speak and we will keep you informed.

Next update no later than 11:00 CEST.
Posted Sep 22, 2026 - 09:58 CEST
This incident affected: Apps (Webmail).