Issues with webmail accessibility
Incident Report for One.com
Resolved
Webmail access has now been fully restored, and all systems are verified to be working as expected again.

If you are still having problems accessing related services with us, please contact us on chat or email here: https://www.one.com/chat.
Posted Jun 10, 2024 - 10:31 CEST
Investigating
We are currently facing issues with our webmail not being accessible. It is being looked into and we will keep you posted.

Next update no later than 11:00 CEST.
Posted Jun 10, 2024 - 10:23 CEST
This incident affected: Services (Mail services).