Exchange account creation not working for new customers
Incident Report for One.com
Resolved
Exchange access has now been fully restored, and all systems are verified to be working as expected again.

If you are still having problems accessing related services with us, please contact us on chat or email here: https://www.one.com/chat.
Posted Aug 07, 2024 - 10:21 CEST
Identified
It is currently not possible to create an Exchange account in our control panel for new customers. Customers who already have an Exchange account can still make new accounts.
We are working on fixing this. We will provide updates here when we have some.
Posted Jul 15, 2024 - 14:33 CEST
This incident affected: Partners (Microsoft Exchange).