Issues with webmail loading slowly
Incident Report for One.com
Resolved
Webmail access has now been fully restored, and all systems are verified to be working as expected again.

If you are still having problems accessing related services with us, please contact us on chat or email here: https://www.one.com/chat.
Posted Jul 01, 2024 - 15:28 CEST
Monitoring
A fix has been implemented, and we are monitoring the situation.
Posted Jul 01, 2024 - 15:16 CEST
Update
This issue is still being investigated by our team. We will let you know as soon as we have more information.

Next update no later than 13:00 CEST.
Posted Jul 01, 2024 - 11:52 CEST
Investigating
We are currently facing issues with our webmail loading slowly for many users. It is being looked into and we will keep you posted.

Next update no later than 12:00 CEST.
Posted Jul 01, 2024 - 10:49 CEST
This incident affected: Services (Mail services).