Exchange account creation not working

Incident Report for One.com

Resolved

Account creation for Exchange accounts, are now working again for all customers.

If you are still having problems accessing related services with us, please contact us on chat or email here: https://www.one.com/chat.
Posted Feb 20, 2025 - 09:49 CET

Identified

Due to issues at Microsoft. It is currently not possible to create Exchange accounts
Posted Feb 19, 2025 - 12:14 CET
This incident affected: Partners (Microsoft Exchange).