Exchange account management problems
Incident Report for One.com
Resolved
Exchange access has now been fully restored, and all systems are verified to be working as expected again.

If you are still having problems accessing related services with us, please contact us on chat or email here: https://www.one.com/chat.
Posted Dec 18, 2023 - 15:25 CET
Identified
We are still facing issues with Exchange accounts. Because of this, new accounts cant be created
Posted Dec 18, 2023 - 11:35 CET
Investigating
We are currently facing issues with managing Exchange accounts, such as deletions and upgrading.

It is being investigated and we will let you know as soon as we can once there is an update.
Posted Dec 14, 2023 - 11:05 CET
This incident affected: Partners (Microsoft Exchange).