Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 29, 2025 - 05:00 CEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 25, 2025 - 10:32 CEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 25, 2025 - 10:10 CEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 25, 2025 - 10:09 CEST
Scheduled
A maintenance window has been scheduled for mail services on the 29th of September from 5:00 to 8:00 CEST.
During the maintenance users will not be able to log in into their email accounts. We expect approximately 30-60 minutes of unavailability during this maintenance.
If you experience any further trouble after the maintenance window has completed, please contact us on chat or email here: https://www.one.com/chat.
We are sorry for any inconvenience caused during the maintenance window.
Posted Sep 25, 2025 - 10:09 CEST
This scheduled maintenance affected: Services (Mail services).