Issues with Microsoft Exchange
Incident Report for One.com
Resolved
Microsoft has resolved the issue on their end. Exchange services are expected to be working again.
Posted Oct 11, 2023 - 22:02 CEST
Identified
Microsoft is currently experiencing issues with Exchange. This causes delays in emails deliverd to Exchange customers and email to fail with an error saying "Server busy, Please try again later".

This is not something we can fix. All we can do is wait for Microsoft to fix this
Posted Oct 11, 2023 - 13:52 CEST
This incident affected: Partners (Microsoft Exchange).