Issues with Office 365 Plus subscriptions

Incident Report for One.com

Resolved

This issue is now fixed.
Posted Dec 17, 2024 - 10:23 CET

Investigating

Due to a recent configuration change by Microsoft certain operations — such as password resets and renewals — are temporarily unavailable for some of our Office 365 Plus subscriptions. We are actively working to resolve this issue and restore full functionality as soon as possible.
Posted Nov 05, 2024 - 08:25 CET
This incident affected: Partners (Microsoft Exchange).