Issue with connection to One.com sites
Incident Report for One.com
Resolved
There is currently a known issue with accessing One.com's website, control panel, and webmail, showing an error message about insecure connection.

Update: It turns out to be caused by the use of an old Mac or OS version. Users facing this issue will need to update their Mac version or use a more recent OS.
Posted Oct 01, 2021 - 09:54 CEST