Exchange account creation not working

Incident Report for One.com

Update

Exisiting customer can once again create new accounts. New customers can still not create accounts.
Posted Jun 19, 2025 - 14:04 CEST

Update

It is currently not possible to create Exchange account in our control panel, for both exsiting and new customers. We are working on fixing this. We wil provide updates here, when we have some.
Posted Jun 19, 2025 - 12:34 CEST

Identified

It is currently not possible to create Exchange accounts in our control panel, for customers who does not already have an account. We are working on fixing this. We wil provide updates here, when we have some.
Posted Jun 17, 2025 - 13:21 CEST
This incident affects: Partners (Microsoft Exchange).