Issues with email service
Incident Report for
Email service access has now been fully restored, and all systems are verified to be working as expected again.

If you are still having problems accessing related services with us, please contact our chat support or write us at
Posted 3 months ago. Dec 19, 2017 - 16:45 CET
We are currently experiencing issues with email service, causing issue logging into email accounts, affecting some customers in Europe.

Our Engineering team is doing all they can to get our systems back to normal as soon as possible.
No data will be lost because of this issue.

We will keep you updated on the progress and resolution of this issue, the first update will be no later than 17:00 CET.
Posted 3 months ago. Dec 19, 2017 - 16:00 CET