Issues with Mail services
Incident Report for One.com
Resolved
Mail services have now been fully restored, and all systems are verified to be working as expected again.

If you are still having problems accessing related services with us, please contact our chat support http://one.com/chat or write us at support@one.com.
Posted 9 months ago. Mar 22, 2018 - 12:26 CET
Investigating
We are currently experiencing issues with our mail servers, causing mails to not being accessible, affecting some customers.

Our Engineering team is doing all they can to get our systems back to normal as soon as possible.
No email will be lost because of this issue.

We will keep you updated on the progress and resolution of this issue, first update will be no later than 12:45 CET/EST.
Posted 9 months ago. Mar 22, 2018 - 12:13 CET