Issues with Mail forwards - Europe
Incident Report for One.com
Resolved
Microsoft have now adjusted the limitation against our IP range to a more appropriate level and mail-queue sizes are almost back to normal.
Posted 10 days ago. Sep 15, 2018 - 00:23 CEST
Update
We see an improvement in the deliverability of forwards towards hotmail/outlook/msn/live now. We do however still have quite a huge backlog of mails that are slowly being handled. We will keep monitoring the situation.
Posted 10 days ago. Sep 14, 2018 - 20:14 CEST
Investigating
We are currently experiencing issues with our mail servers, causing certain mails to not be forwarded to, affecting customers in Europe.

This affects mail forwards to hotmail/outlook/office365 e-mail accounts. It only happens if a mail forwards for an e-mail hosted here is set up. Mails sent directly to those addresses should be delivered fine.

Our Engineering team is doing all they can to get this situation back to normal as soon as possible.

As soon as we have any news, we will update the status accordingly.
Posted 10 days ago. Sep 14, 2018 - 13:30 CEST
This incident affected: General availability and Europe (Mail services).