Issues with Website hosting - Europe
Incident Report for
Website access has now been fully restored, and all systems are verified to be working as expected again.

If you are still having problems accessing related services with us, please contact our chat support or write us at
Posted 3 months ago. Dec 12, 2017 - 15:46 CET
Our Engineering team is still working on resolving the website hosting issue as soon as possible.

Next update no later than 16:00 CET.
Posted 3 months ago. Dec 12, 2017 - 14:58 CET
We are currently experiencing issues with Website hosting, causing error messages, time-outs or blank pages while trying to access websites or using FTP/SSH, affecting some customers in Europe.

Our Engineering team is doing all they can to get our systems back to normal as soon as possible.
No data will be lost because of this issue.

We will keep you updated on the progress and resolution of this issue, the first update will be no later than 15:00 CET.
Posted 3 months ago. Dec 12, 2017 - 14:13 CET