Issues with Mail services
Incident Report for One.com
Resolved
Webmail access has now been fully restored, and all systems are verified to be working as expected again.

If you are still having problems accessing related services with us, please contact our chat support http://one.com/chat or write us at support@one.com.
Posted 2 months ago. Nov 20, 2017 - 09:21 CET
Investigating
We are currently experiencing Webmail access issues.

Our Engineering team is doing all they can to get our systems back to normal as soon as possible.
No email will be lost because of this issue.

We will keep you updated on the progress and resolution of this issue, the first update will be no later than 09.30 CET.
Posted 2 months ago. Nov 20, 2017 - 08:59 CET